GitHub Advisoryadvisory · Packagist

GHSA-mj85-3hqq-r6r9 Moodle Reflected XSS in mod_data advanced search

MEDIUM Published 2022-05-13 Modified 2024-01-26 Official page ↗
Aliases
CVE-2016-2153
Ecosystem
Packagist
Packages
moodle/moodle
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-01-26

Affected packages

• Packagist moodle/moodle: >= 2.7, < 2.7.13 → fixed in 2.7.13 • Packagist moodle/moodle: >= 2.8, < 2.8.11 → fixed in 2.8.11 • Packagist moodle/moodle: >= 2.9, < 2.9.5 → fixed in 2.9.5 • Packagist moodle/moodle: >= 3.0, < 3.0.3 → fixed in 3.0.3

Description

Cross-site scripting (XSS) vulnerability in the advanced-search feature in mod_data in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x before 2.8.11, 2.9.x before 2.9.5, and 3.0.x before 3.0.3 allows remote attackers to inject arbitrary web script or HTML via a crafted field in a URL, as demonstrated by a search form field.

Related

Alias · CVE (1)

  • CVE-2016-2153 Cross-site scripting (XSS) vulnerability in the advanced-search feature in mod_data in Moodle through 2.6.11, 2.7.x before 2.7.13, 2.8.x… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References