GitHub Advisoryadvisory · Packagist

GHSA-mjgw-f2c4-f8qj WebPA SQL Injection vulnerability

CRITICAL Published 2023-01-08 Modified 2023-01-12 Official page ↗
Aliases
CVE-2021-4308
Ecosystem
Packagist
Packages
webpa/webpa
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2023-01-12

Affected packages

• Packagist webpa/webpa: < 3.1.2 → fixed in 3.1.2

Description

A vulnerability was found in WebPA up to 3.1.1. It has been rated as critical. This issue affects some unknown processing. The manipulation leads to sql injection. Upgrading to version 3.1.2 can to address this issue. The name of the patch is 8836c4f549181e885a68e0e7ca561fdbcbd04bf0. It is recommended to upgrade the affected component. The identifier VDB-217637 was assigned to this vulnerability.

Related

Alias · CVE (1)

  • CVE-2021-4308 A vulnerability was found in WebPA up to 3.1.1. vulnerability

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References