GitHub Advisoryadvisory · Maven

GHSA-mjvf-4h88-6xm3 Improper Authentication vulnerability in Apache Solr

CRITICAL Published 2024-10-16 Modified 2025-07-02 Official page ↗
Aliases
CVE-2024-45216
Ecosystem
Maven
Packages
org.apache.solr:solr
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-287, CWE-863
Reviewed
2024-10-16

Affected packages

• Maven org.apache.solr:solr: >= 5.3.0, < 8.11.4 → fixed in 8.11.4 • Maven org.apache.solr:solr: >= 9.0.0, < 9.7.0 → fixed in 9.7.0

Description

Solr instances using the PKIAuthenticationPlugin, which is enabled by default when Solr Authentication is used, are vulnerable to Authentication bypass. A fake ending at the end of any Solr API URL path, will allow requests to skip Authentication while maintaining the API contract with the original URL Path. This fake ending looks like an unprotected API path, however it is stripped off internally after authentication but before API routing. This issue affects Apache Solr: from 5.3.0 before 8.11.4, from 9.0.0 before 9.7.0. Users are recommended to upgrade to version 9.7.0, or 8.11.4, which fix the issue.

Related

Alias · CVE (1)

  • CVE-2024-45216 Improper Authentication vulnerability in Apache Solr. vulnerability

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-863 Incorrect Authorization weakness

References