GitHub Advisoryadvisory · Packagist
GHSA-mm87-rrqx-94cr Magento stored Cross-Site Scripting (XSS) vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2025-24428
- Ecosystem
- Packagist
- Packages
- magento/community-edition, magento/project-community-edition
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2025-02-28
Affected packages
• Packagist magento/community-edition: >= 2.4.7-beta1, < 2.4.7-p4 → fixed in 2.4.7-p4
• Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p9 → fixed in 2.4.6-p9
• Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p11 → fixed in 2.4.5-p11
• Packagist magento/community-edition: < 2.4.4-p12 → fixed in 2.4.4-p12
• Packagist magento/community-edition: 2.4.7 (no fix yet)
• Packagist magento/community-edition: 2.4.6 (no fix yet)
• Packagist magento/community-edition: 2.4.5 (no fix yet)
• Packagist magento/community-edition: 2.4.4 (no fix yet)
• Packagist magento/community-edition: 2.4.8-beta1 (no fix yet)
• Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)
Description
Adobe Commerce versions 2.4.7-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a low-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field.
Related
Alias · CVE (1)
- CVE-2025-24428 Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by a stored Cross-Site Scripting… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness