GitHub Advisoryadvisory · RubyGems

GHSA-mmrq-6999-72v8 Ruby Openssl Allows Incorrect Value Comparison

CRITICAL Published 2022-05-13 Modified 2023-07-24 Official page ↗
Aliases
CVE-2018-16395
Ecosystem
RubyGems
Packages
openssl
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Reviewed
2023-06-09

Affected packages

• RubyGems openssl: < 2.0.9 → fixed in 2.0.9 • RubyGems openssl: >= 2.1.0, < 2.1.2 → fixed in 2.1.2

Description

An issue was discovered in the OpenSSL library in Ruby when two `OpenSSL::X509::Name` objects are compared using `==`, depending on the ordering, non-equal objects may return true. When the first argument is one character longer than the second, or the second argument contains a character that is one less than a character in the same position of the first argument, the result of `==` will be true. This could be leveraged to create an illegitimate certificate that may be accepted as legitimate and then used in signing or encryption operations.

Related

Alias · CVE (1)

  • CVE-2018-16395 An issue was discovered in the OpenSSL library in Ruby before 2.3.8, 2.4.x before 2.4.5, 2.5.x before 2.5.2, and 2.6.x before… vulnerability

References