GitHub Advisoryadvisory · PyPI
GHSA-mp5p-g2jv-r8qw rdiffweb contains Weak Password Requirements
HIGH
Official page ↗
- Aliases
- CVE-2022-3179
- Ecosystem
- PyPI
- Packages
- rdiffweb
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-521
- Reviewed
- 2022-09-15
Affected packages
• PyPI rdiffweb: >= 2.4.1, < 2.4.2 → fixed in 2.4.2
Description
rdiffweb version 2.4.1 has no password policy or password checking, which could make users vulnerable to brute force password guessing attacks. Version 2.4.2 enforces minimum and maximum password lengths.
Related
Alias · CVE (1)
- CVE-2022-3179 Weak Password Requirements in GitHub repository ikus060/rdiffweb prior to 2.4.2. vulnerability
Weakness · CWE (1)
- CWE-521 Weak Password Requirements weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2022-3179 advisory
- https://github.com/ikus060/rdiffweb/commit/233befc33bdc45d4838c773d5aed4408720504c5 web
- https://github.com/advisories/GHSA-mp5p-g2jv-r8qw advisory
- https://github.com/ikus060/rdiffweb package
- https://github.com/pypa/advisory-database/tree/main/vulns/rdiffweb/PYSEC-2022-272.yaml web
- https://huntr.dev/bounties/58eae29e-3619-449d-9bba-fdcbabcba5fe web