GitHub Advisoryadvisory · Go

GHSA-mp6x-97xj-9x62 Mattermost fails to to verify the token used during code exchange

CRITICAL Published 2025-11-27 Modified 2025-12-01 Official page ↗
Aliases
CVE-2025-12421
Ecosystem
Go
Packages
github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-287, CWE-303
Reviewed
2025-12-01

Affected packages

• Go github.com/mattermost/mattermost/server/v8: < 8.0.0-20251022210333-acda1fb5dd46 → fixed in 8.0.0-20251022210333-acda1fb5dd46 • Go github.com/mattermost/mattermost-server: >= 11.0.0, < 11.0.3 → fixed in 11.0.3 • Go github.com/mattermost/mattermost-server: >= 10.12.0, < 10.12.2 → fixed in 10.12.2 • Go github.com/mattermost/mattermost-server: >= 10.11.0, < 10.11.5 → fixed in 10.11.5 • Go github.com/mattermost/mattermost-server: >= 10.5.0, < 10.5.13 → fixed in 10.5.13

Description

Mattermost versions 11.0.x <= 11.0.2, 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to to verify that the token used during the code exchange originates from the same authentication flow, which allows an authenticated user to perform account takeover via a specially crafted email address used when switching authentication methods and sending a request to the /users/login/sso/code-exchange endpoint. The vulnerability requires ExperimentalEnableAuthenticationTransfer to be enabled (default: enabled) and RequireEmailVerification to be disabled (default: disabled).

Related

Alias · CVE (1)

  • CVE-2025-12421 Mattermost versions 11.0.x <= 11.0.2, 10.12.x <= 10.12.1, 10.11.x <= 10.11.4, 10.5.x <= 10.5.12 fail to to verify that the token used… vulnerability

Weakness · CWE (2)

  • CWE-287 Improper Authentication weakness
  • CWE-303 Incorrect Implementation of Authentication Algorithm weakness

References