GitHub Advisoryadvisory · RubyGems
GHSA-mp78-r56v-45qc ember-source vulnerable to Cross-site Scripting
MEDIUM
Official page ↗
- Aliases
- CVE-2015-1866
- Ecosystem
- RubyGems
- Packages
- ember-source
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2020-06-16
Affected packages
• RubyGems ember-source: >= 1.10.0, < 1.10.1 → fixed in 1.10.1
• RubyGems ember-source: >= 1.11.0, < 1.11.2 → fixed in 1.11.2
Description
Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.
Related
Alias · CVE (1)
- CVE-2015-1866 Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2015-1866 advisory
- https://emberjs.com/blog/2015/04/14/security-and-bugfix-releases-ember-1-10-1-1-11-2-1-11-3.html web
- https://github.com/Acidburn0zzz/ember.js package
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ember-source/CVE-2015-1866.yml web
- https://groups.google.com/forum/#!topic/ember-security/nbntfs2EbRU web
- https://web.archive.org/web/20200228155301/http://www.securityfocus.com/bid/74185 web
- http://www.openwall.com/lists/oss-security/2015/04/14/11 web