GitHub Advisoryadvisory · Packagist
GHSA-mp9r-rh95-f8f8 Magento 2 Community Edition RCE Vulnerability
HIGH
Official page ↗
- Aliases
- CVE-2019-7885
- Ecosystem
- Packagist
- Packages
- magento/community-edition
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2023-07-17
Affected packages
• Packagist magento/community-edition: >= 2.1, < 2.1.18 → fixed in 2.1.18
• Packagist magento/community-edition: >= 2.2, < 2.2.9 → fixed in 2.2.9
• Packagist magento/community-edition: >= 2.3, < 2.3.2 → fixed in 2.3.2
Description
Insufficient input validation in the config builder of the Elastic search module could lead to remote code execution in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2. This vulnerability could be abused by an authenticated user with the ability to configure the catalog search.
Related
Alias · CVE (1)
- CVE-2019-7885 Insufficient input validation in the config builder of the Elastic search module could lead to remote code execution in Magento 2.1 prior… vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2019-7885 advisory
- https://github.com/FriendsOfPHP/security-advisories/blob/master/magento/product-community-edition/CVE-2019-7885.yaml web
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13 web
- https://web.archive.org/web/20211206084839/https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13 web