GitHub Advisoryadvisory · Go
GHSA-mpc7-mm28-f6wq Mattermost allows authenticated guest users to enumerate user IDs outside their allowed visibility scope
MEDIUM
Official page ↗
- Aliases
- CVE-2026-3115
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost/server/v8
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2026-03-31
Affected packages
• Go github.com/mattermost/mattermost/server/v8: >= 11.4.0, < 11.4.1 → fixed in 11.4.1
• Go github.com/mattermost/mattermost/server/v8: >= 11.3.0-rc1, < 11.3.2 → fixed in 11.3.2
• Go github.com/mattermost/mattermost/server/v8: >= 11.2.0-rc1, < 11.2.3 → fixed in 11.2.3
• Go github.com/mattermost/mattermost/server/v8: >= 10.11.0-rc1, < 10.11.11 → fixed in 10.11.11
• Go github.com/mattermost/mattermost/server/v8: >= 8.0.0-20260105080200-d27a2195068d, < 8.0.0-20260217110922-b7d4a1f1f59b → fixed in 8.0.0-20260217110922-b7d4a1f1f59b
Description
Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to apply view restrictions when retrieving group member IDs, which allows authenticated guest users to enumerate user IDs outside their allowed visibility scope via the group retrieval endpoint. Mattermost Advisory ID: MMSA-2026-00594.
Related
Alias · CVE (1)
- CVE-2026-3115 Mattermost versions 11.2.x <= 11.2.2, 10.11.x <= 10.11.10, 11.4.x <= 11.4.0, 11.3.x <= 11.3.1 fail to apply view restrictions when… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness