GitHub Advisoryadvisory · Packagist
GHSA-mpg7-2rx9-h5qp Contao Cross-site Scripting vulnerabililty
MEDIUM
Official page ↗
- Aliases
- CVE-2018-5478
- Ecosystem
- Packagist
- Packages
- contao/core
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-15
Affected packages
• Packagist contao/core: >= 3.0.0, < 3.5.32 → fixed in 3.5.32
Description
Contao 3.x before 3.5.32 allows Cross-site Scripting (XSS) via the unsubscribe module in the frontend newsletter extension.
Related
Alias · CVE (1)
- CVE-2018-5478 Contao 3.x before 3.5.32 allows XSS via the unsubscribe module in the frontend newsletter extension. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-5478 advisory
- https://github.com/contao/core/commit/3123d6527ae6c46087b0ad8061eb8651cb645b8d web
- https://contao.org/en/news/contao-3_5_32.html web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/contao/core/CVE-2018-5478.yaml web
- https://github.com/contao/core package
- https://security.snyk.io/vuln/SNYK-PHP-CONTAOCORE-70397 web