GitHub Advisoryadvisory · Packagist
GHSA-mpqj-f4v3-334h Silverstripe Cross-site scripting vulnerability in VersionedRequestFilter
MEDIUM
Official page ↗
- Ecosystem
- Packagist
- Packages
- silverstripe/framework
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-05-23
Affected packages
• Packagist silverstripe/framework: >= 3.3.2, < 3.3.3 → fixed in 3.3.3
• Packagist silverstripe/framework: >= 3.4.0, < 3.4.1 → fixed in 3.4.1
Description
A cross-site scripting vulnerability in VersionedRequestFilter has been found.
If an incoming user request should not be able to access the requested stage, an error message is created for display on the CMS login page that they are redirected to. In this error message, the URL of the requested page is interpolated into the error message without being escaped; hence, arbitrary HTML can be injected into the CMS login page.
Related
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/silverstripe/silverstripe-framework/commit/3fa84cf0c64a539d78600c36364817a8e38411d8 web
- https://github.com/silverstripe/silverstripe-framework/commit/41be95c95a55031412ee4056aeee5c2c69595836 web
- https://github.com/FriendsOfPHP/security-advisories/blob/master/silverstripe/framework/SS-2016-007-1.yaml web
- https://github.com/silverstripe/silverstripe-framework package
- https://www.silverstripe.org/download/security-releases/ss-2016-007 web