GitHub Advisoryadvisory · RubyGems

GHSA-mpxf-gcw2-pw5q actionpack Improper Input Validation vulnerability

MEDIUM Published 2017-10-24 Modified 2023-07-31 Official page ↗
Aliases
CVE-2013-6414
Ecosystem
RubyGems
Packages
actionpack
Severity
Moderate
Weaknesses
CWE-20
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: >= 3.0.0, < 3.2.16 → fixed in 3.2.16 • RubyGems actionpack: >= 4.0.0, < 4.0.2 → fixed in 4.0.2

Description

`actionpack/lib/action_view/lookup_context.rb` in Action View in Ruby on Rails 3.x before 3.2.16 and 4.x before 4.0.2 allows remote attackers to cause a denial of service (memory consumption) via a header containing an invalid MIME type that leads to excessive caching.

Related

Alias · CVE (1)

  • CVE-2013-6414 actionpack/lib/action_view/lookup_context.rb in Action View in Ruby on Rails 3.x before 3.2.16 and 4.x before 4.0.2 allows remote attackers… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References