GitHub Advisoryadvisory · Go
GHSA-mq5q-gpgv-pwxw usememos/memos Incorrect Use of Privileged APIs vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2022-4805
- Ecosystem
- Go
- Packages
- github.com/usememos/memos
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-648
- Reviewed
- 2022-12-30
Affected packages
• Go github.com/usememos/memos: < 0.9.1 → fixed in 0.9.1
Description
In usememos/memos 0.9.0 and prior, a user can archive any private memos, delete any shortcut, and edit any shortcut from other users via API.
Related
Alias · CVE (1)
- CVE-2022-4805 Incorrect Use of Privileged APIs in GitHub repository usememos/memos prior to 0.9.1. vulnerability
Weakness · CWE (1)
- CWE-648 Incorrect Use of Privileged APIs weakness