GitHub Advisoryadvisory · Packagist

GHSA-mqf5-275h-gf6r Silverstripe framework is vulnerable to XSS in install.php

MEDIUM Published 2024-05-23 Modified 2024-05-23 Official page ↗
Ecosystem
Packagist
Packages
silverstripe/framework
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2024-05-23

Affected packages

• Packagist silverstripe/framework: >= 3.1.0, < 3.1.14 → fixed in 3.1.14

Description

During installation, certain parameters (admin_username and admin_password) are not escaped in the setup form. This issue is resolved in 3.1.14 stable, although existing users are advised to remove this file prior to deploying to a production server.

Related

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References