GitHub Advisoryadvisory · Packagist
GHSA-mqw9-3cjm-xwp3 Moodle Minor SQL injection risk in admin user browsing
CRITICAL
Official page ↗
- Aliases
- CVE-2022-40315
- Ecosystem
- Packagist
- Packages
- moodle/moodle
- Severity
- Critical
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-89
- Reviewed
- 2024-04-23
Affected packages
• Packagist moodle/moodle: >= 3.9, < 3.9.17 → fixed in 3.9.17
• Packagist moodle/moodle: >= 3.11, < 3.11.10 → fixed in 3.11.10
• Packagist moodle/moodle: >= 4.0, < 4.0.4 → fixed in 4.0.4
Description
A limited SQL injection risk was identified in the "browse list of users" site administration page.
Related
Alias · CVE (1)
- CVE-2022-40315 A limited SQL injection risk was identified in the "browse list of users" site administration page. vulnerability
Weakness · CWE (1)
- CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness