GitHub Advisoryadvisory · RubyGems

GHSA-mqwr-4qf2-2hcv RubyGems vulnerable to Deserialization of Untrusted Data

CRITICAL Published 2022-05-13 Modified 2023-03-09 Official page ↗
Aliases
CVE-2017-0903
Ecosystem
RubyGems
Packages
rubygems-update
Severity
Critical
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2023-03-09

Affected packages

• RubyGems rubygems-update: >= 2.0.0, < 2.6.14 → fixed in 2.6.14

Description

RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. YAML deserialization of gem specifications can bypass class white lists. Specially crafted serialized objects can possibly be used to escalate to remote code execution. The issue has been patched in 2.6.14.

Related

Alias · CVE (1)

  • CVE-2017-0903 RubyGems versions between 2.0.0 and 2.6.13 are vulnerable to a possible remote code execution vulnerability. vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References