GitHub Advisoryadvisory · Maven

GHSA-mrqp-q7vx-v2cx Instaclustr Cassandra-Lucene-Index allows bypass of Cassandra RBAC

HIGH Published 2025-02-13 Modified 2026-01-22 Official page ↗
Aliases
CVE-2025-26511
Ecosystem
Maven
Packages
com.instaclustr:cassandra-lucene-index-plugin
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-288, CWE-863
Reviewed
2025-02-13

Affected packages

• Maven com.instaclustr:cassandra-lucene-index-plugin: >= 4.0-rc1-1.0.0, < 4.0.17-1.0.0 → fixed in 4.0.17-1.0.0 • Maven com.instaclustr:cassandra-lucene-index-plugin: >= 4.1.0-1.0.0, < 4.1.8-1.0.1 → fixed in 4.1.8-1.0.1

Description

Summary / Details Systems running the Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0 and 4.1.0-1.0.0 through 4.1.8-1.0.0, installed into Apache Cassandra version 4.x, are susceptible to a vulnerability which when successfully exploited could allow authenticated Cassandra users to remotely bypass RBAC to access data and and escalate their privileges. Affected Versions - Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0 - versions 4.1.0-1.0.0 through 4.1.8-1.0.0 when installed into Apache Cassandra version 4.x. Required Configuration for Exploit These are the conditions required to enable exploit: 1. Cassandra 4.x 2. Vulnerable version of the Cassandra-Lucene-Index plugin configured for use 3. Data added to tables 4. Lucene index created 5. Cassandra flush has run Mitigation/Prevention Mitigation requires dropping all Lucene indexes and stopping use of the plugin. Exploit will be possible any time the required conditions are met. Solution Upgrade to a fixed version of the Cassandra-Lucene-Index plugin. Review users in Cassandra to validate all superuser privileges.

Related

Alias · CVE (1)

  • CVE-2025-26511 Systems running the Instaclustr fork of Stratio's Cassandra-Lucene-Index plugin versions 4.0-rc1-1.0.0 through 4.0.16-1.0.0 and 4.1.2-1.0.0… vulnerability

Weakness · CWE (2)

  • CWE-288 Authentication Bypass Using an Alternate Path or Channel weakness
  • CWE-863 Incorrect Authorization weakness

References