GitHub Advisoryadvisory · Packagist

GHSA-mrqx-mjc4-vfh3 wallabag subject to Improper Authorization via annotations

MEDIUM Published 2023-02-02 Modified 2023-02-02 Official page ↗
Aliases
CVE-2023-0610
Ecosystem
Packagist
Packages
wallabag/wallabag
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Reviewed
2023-02-02

Affected packages

• Packagist wallabag/wallabag: >= 2.0.0-beta.1, < 2.5.3 → fixed in 2.5.3

Description

Impact The annotations feature lets users add annotations on highlighted parts of an entry. The controller does not validate authorization on `PUT` and `DELETE` requests which lets a logged user modify or delete any annotation using their ID on their endpoints `example.org/annotations/{id}`. These vulnerable requests also disclose highlighted parts of the entry to the attacker. You should immediately patch your instance to version 2.5.3 or higher if you have more than one user and/or having open registration. Resolution A user check is now done in the vulnerable methods before applying change on an annotation. The Annotation retrieval through a `ParamConverter` has also been replaced with a call to the `AnnotationRepository` in order to prevent any information disclosure through response discrepancy. Workarounds Credits We would like to thank @bAuh0lz for reporting this issue through huntr.dev. Reference: https://huntr.dev/bounties/8fdd9b31-d89b-4bbe-9557-20b960faf926/

Related

Alias · CVE (1)

  • CVE-2023-0610 Improper Authorization in GitHub repository wallabag/wallabag prior to 2.5.3. vulnerability

References