GitHub Advisoryadvisory · npm
GHSA-mrr8-v49w-3333 sweetalert2 contains potentially undesirable behavior
LOW
Official page ↗
- Ecosystem
- npm
- Packages
- sweetalert2
- Severity
- Low
- Weaknesses
- CWE-440
- Reviewed
- 2023-07-10
Affected packages
• npm sweetalert2: >= 11.6.14, < 11.22.4 → fixed in 11.22.4
Description
`sweetalert2` versions from 11.6.14 to before 11.22.4 have potentially undesirable behavior. The package outputs audio and/or video messages that do not pertain to the functionality of the package when run on specific tlds. This functionality is documented on the project's readme.
Related
Weakness · CWE (1)
- CWE-440 Expected Behavior Violation weakness
References
- https://github.com/sweetalert2/sweetalert2/pull/2847 web
- https://github.com/sweetalert2/sweetalert2/commit/7de85db5c76ba3ef5f0cdbc335bbc4a7c559e012 web
- https://github.com/sweetalert2/sweetalert2 package
- https://github.com/sweetalert2/sweetalert2/releases/tag/v11.4.9 web
- https://github.com/sweetalert2/sweetalert2/tree/6d02e1095e5d9db1dfa7f0708df6fa13a1b32be3#important-notice-about-usage-of-this-software-for-ru-su-and-%D1%80%D1%84-domain-zones web
- https://www.npmjs.com/package/sweetalert2 web