GitHub Advisoryadvisory · PyPI

GHSA-mv2w-4jqc-6fg4 Command injection in libvcs and vcspull

CRITICAL Published 2022-03-15 Modified 2024-09-27 Official page ↗
Aliases
CVE-2022-21187
Ecosystem
PyPI
Packages
libvcs, vcspull
Severity
Critical
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-74, CWE-77
Reviewed
2022-03-15

Affected packages

• PyPI libvcs: < 0.11.1 → fixed in 0.11.1 • PyPI vcspull: < 1.11.1 → fixed in 1.11.1

Description

The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. When calling the update_repo function (when using hg), the url parameter is passed to the hg clone command. By injecting some hg options it was possible to get arbitrary command execution.

Related

Alias · CVE (1)

  • CVE-2022-21187 The package libvcs before 0.11.1 are vulnerable to Command Injection via argument injection. vulnerability

Weakness · CWE (2)

  • CWE-74 Improper Neutralization of Special Elements in Output Used by a Downstream Component weakness
  • CWE-77 Improper Neutralization of Special Elements used in a Command weakness

References