GitHub Advisoryadvisory · Packagist
GHSA-mv3p-7p89-wq9p Connect CMS has Stored Cross-site Scripting (XSS) in the File Field of its Form Plugin
HIGH
Official page ↗
- Aliases
- CVE-2026-32278
- Ecosystem
- Packagist
- Packages
- opensource-workshop/connect-cms
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:L
- Weaknesses
- CWE-434, CWE-79
- Reviewed
- 2026-03-23
Affected packages
• Packagist opensource-workshop/connect-cms: < 1.41.1 → fixed in 1.41.1
• Packagist opensource-workshop/connect-cms: >= 2.0.0, < 2.41.1 → fixed in 2.41.1
Description
Security Advisory — Form Plugin (Stored XSS)
Summary
A Stored Cross-site Scripting (XSS) issue exists in the file field of the Form Plugin.
Affected Versions
• 1.x series: <= 1.41.0
• 2.x series: <= 2.41.0
Patched Versions
• 1.41.1
• 2.41.1
Description
In the file field of the Form Plugin, Stored Cross-site Scripting (XSS) could occur. If exploited, arbitrary script could run in an administrator's browser, which may lead to unauthorized actions or information theft. Users affected by this vulnerability should update to a fixed version.
Solution
Update to the fixed version.
For the 1.x series, update to 1.41.1 or later.
For the 2.x series, update to 2.41.1 or later.
Credits
OpenSource WorkShop thanks Sho Odagiri (小田切 祥) of GMO Cybersecurity by Ierae, Inc. for reporting this vulnerability.
Related
Alias · CVE (1)
- CVE-2026-32278 Connect-CMS is a content management system. vulnerability
References
- https://github.com/opensource-workshop/connect-cms/security/advisories/GHSA-mv3p-7p89-wq9p web
- https://nvd.nist.gov/vuln/detail/CVE-2026-32278 advisory
- https://github.com/opensource-workshop/connect-cms/commit/9d87fe8ecf7f57efbb0e5231be058807734c96b3 web
- https://github.com/opensource-workshop/connect-cms package
- https://github.com/opensource-workshop/connect-cms/releases/tag/v1.41.1 web
- https://github.com/opensource-workshop/connect-cms/releases/tag/v2.41.1 web