GitHub Advisoryadvisory · npm

GHSA-mvjj-gqq2-p4hw Cross-Site Scripting in react-dom

MEDIUM Published 2019-01-04 Modified 2023-09-13 Official page ↗
Aliases
CVE-2018-6341
Ecosystem
npm
Packages
react-dom
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• npm react-dom: >= 16.0.0, < 16.0.1 → fixed in 16.0.1 • npm react-dom: >= 16.1.0, < 16.1.2 → fixed in 16.1.2 • npm react-dom: >= 16.2.0, < 16.2.1 → fixed in 16.2.1 • npm react-dom: >= 16.3.0, < 16.3.3 → fixed in 16.3.3 • npm react-dom: >= 16.4.0, < 16.4.2 → fixed in 16.4.2

Description

Affected versions of `react-dom` are vulnerable to Cross-Site Scripting (XSS). The package fails to validate attribute names in HTML tags which may lead to Cross-Site Scripting in specific scenarios. This may allow attackers to execute arbitrary JavaScript in the victim's browser. To be affected by this vulnerability, the application needs to: • be a server-side React app • be rendered to HTML using `ReactDOMServer` • include an attribute name from user input in an HTML tag Recommendation If you are using `react-dom` 16.0.x, upgrade to 16.0.1 or later. If you are using `react-dom` 16.1.x, upgrade to 16.1.2 or later. If you are using `react-dom` 16.2.x, upgrade to 16.2.1 or later. If you are using `react-dom` 16.3.x, upgrade to 16.3.3 or later. If you are using `react-dom` 16.4.x, upgrade to 16.4.2 or later.

Related

Alias · CVE (1)

  • CVE-2018-6341 React applications which rendered to HTML using the ReactDOMServer API were not escaping user-supplied attribute names at render-time. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References