GitHub Advisoryadvisory · Packagist

GHSA-mw37-wx8p-gp45 Craft CMS vulnerable to Cross-site Scripting via entry revisions and drafts

MEDIUM Published 2022-09-17 Modified 2022-09-26 Official page ↗
Aliases
CVE-2022-37251
Ecosystem
Packagist
Packages
craftcms/cms
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2022-09-20

Affected packages

• Packagist craftcms/cms: >= 3.7.0-beta.1, < 3.7.55.2 → fixed in 3.7.55.2 • Packagist craftcms/cms: >= 4.0.0-RC1, < 4.2.1 → fixed in 4.2.1

Description

Craft CMS `3.70-RC1`–`3.7.55.1` and `4.0.0-RC1`–`4.2.0.1` are vulnerable to Cross Site Scripting (XSS) via entry revisions and drafts. Versions `3.7.55.2` and `4.2.1` contain patches for this issue.

Related

Alias · CVE (1)

  • CVE-2022-37251 Craft CMS 4.2.0.1 is vulnerable to Cross Site Scripting (XSS) via Drafts. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References