GitHub Advisoryadvisory · Maven

GHSA-mw3v-mmfw-3x2g OpenSearch is vulnerable to DoS via complex query_string inputs

HIGH Published 2025-11-25 Modified 2026-01-22 Official page ↗
Aliases
CVE-2025-9624
Ecosystem
Maven
Packages
org.opensearch:opensearch-common
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:H
Weaknesses
CWE-674
Reviewed
2025-11-26

Affected packages

• Maven org.opensearch:opensearch-common: >= 3.0.0, < 3.3.0 → fixed in 3.3.0 • Maven org.opensearch:opensearch-common: < 2.19.4 → fixed in 2.19.4

Description

A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs. This issue affects all OpenSearch versions below 2.19.4 and versions 3.0.0 through 3.2.0.

Related

Alias · CVE (1)

  • CVE-2025-9624 A vulnerability in OpenSearch allows attackers to cause Denial of Service (DoS) by submitting complex query_string inputs. vulnerability

Weakness · CWE (1)

  • CWE-674 Uncontrolled Recursion weakness

References