GitHub Advisoryadvisory · PyPI
GHSA-mw6v-crh8-8533 Integer Overflow or Wraparound in Google TensorFlow
CRITICAL
Official page ↗
- Aliases
- CVE-2018-7575
- Ecosystem
- PyPI
- Packages
- tensorflow, tensorflow-gpu
- Severity
- Critical
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-190
- Reviewed
- 2019-04-30
Affected packages
• PyPI tensorflow: >= 1.0.0, < 1.7.1 → fixed in 1.7.1
• PyPI tensorflow-gpu: >= 1.0.0, < 1.7.1 → fixed in 1.7.1
Description
Issue Description
Google TensorFlow 1.7.x and earlier is affected by a Buffer Overflow vulnerability. The type of exploitation is context-dependent. The block size in meta file might contain a large int64 value which causes an integer overflow upon addition. Subsequent code using n as index may cause an out-of-bounds read.
Impact
A maliciously crafted meta checkpoint could be used to cause the TensorFlow process to perform an out of bounds read on in process memory.
Related
Alias · CVE (1)
- CVE-2018-7575 Google TensorFlow 1.7.x and earlier is affected by a Buffer Overflow vulnerability. vulnerability
Weakness · CWE (1)
- CWE-190 Integer Overflow or Wraparound weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-7575 advisory
- https://github.com/tensorflow/tensorflow/commit/d107fee1e4a9a4462f01564798d345802acc2aef web
- https://github.com/advisories/GHSA-mw6v-crh8-8533 advisory
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2019-223.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2019-230.yaml web
- https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2019-205.yaml web
- https://github.com/tensorflow/tensorflow package
- https://github.com/tensorflow/tensorflow/blob/master/tensorflow/security/advisory/tfsa-2018-004.md web