GitHub Advisoryadvisory · Go
GHSA-mw99-9chc-xw7r Maliciously crafted Git server replies can cause DoS on go-git clients
HIGH
Official page ↗
- Aliases
- CVE-2023-49568
- Ecosystem
- Go
- Packages
- github.com/go-git/go-git/v5, gopkg.in/src-d/go-git.v4
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-20
- Reviewed
- 2023-12-27
Affected packages
• Go github.com/go-git/go-git/v5: < 5.11.0 → fixed in 5.11.0
• Go gopkg.in/src-d/go-git.v4: >= 4.7.1, <= 4.13.1 (no fix yet)
Description
Impact
A denial of service (DoS) vulnerability was discovered in go-git versions prior to `v5.11`. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in `go-git` clients.
Applications using only the in-memory filesystem supported by `go-git` are not affected by this vulnerability.
This is a `go-git` implementation issue and does not affect the upstream `git` cli.
Patches
Users running versions of `go-git` from `v4` and above are recommended to upgrade to `v5.11` in order to mitigate this vulnerability.
Workarounds
In cases where a bump to the latest version of `go-git` is not possible, we recommend limiting its use to only trust-worthy Git servers.
Credit
Thanks to Ionut Lalu for responsibly disclosing this vulnerability to us.
References
• GHSA-mw99-9chc-xw7r
Related
Alias · CVE (1)
- CVE-2023-49568 A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.11. vulnerability
Weakness · CWE (1)
- CWE-20 Improper Input Validation weakness