GitHub Advisoryadvisory · npm
GHSA-mwv6-3258-q52c Next Vulnerable to Denial of Service with Server Components
HIGH
Official page ↗
- Ecosystem
- npm
- Packages
- next
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-1395, CWE-400, CWE-502
- Reviewed
- 2025-12-11
Affected packages
• npm next: >= 13.3.0, < 14.2.34 → fixed in 14.2.34
• npm next: >= 15.0.0-canary.0, < 15.0.6 → fixed in 15.0.6
• npm next: >= 15.1.1-canary.0, < 15.1.10 → fixed in 15.1.10
• npm next: >= 15.2.0-canary.0, < 15.2.7 → fixed in 15.2.7
• npm next: >= 15.3.0-canary.0, < 15.3.7 → fixed in 15.3.7
• npm next: >= 15.4.0-canary.0, < 15.4.9 → fixed in 15.4.9
• npm next: >= 15.5.1-canary.0, < 15.5.8 → fixed in 15.5.8
• npm next: >= 15.6.0-canary.0, < 15.6.0-canary.59 → fixed in 15.6.0-canary.59
• npm next: >= 16.0.0-beta.0, < 16.0.9 → fixed in 16.0.9
• npm next: >= 16.1.0-canary.0, < 16.1.0-canary.17 → fixed in 16.1.0-canary.17
Description
A vulnerability affects certain React packages for versions 19.0.0, 19.0.1, 19.1.0, 19.1.1, 19.1.2, 19.2.0, and 19.2.1 and frameworks that use the affected packages, including Next.js 15.x and 16.x using the App Router. The issue is tracked upstream as CVE-2025-55184.
A malicious HTTP request can be crafted and sent to any App Router endpoint that, when deserialized, can cause the server process to hang and consume CPU. This can result in denial of service in unpatched environments.