GitHub Advisoryadvisory · Packagist

GHSA-mxc9-g6m4-2v35 Magento Open Source allows Improper Neutralization of Special Elements Used

HIGH Published 2023-08-09 Modified 2025-03-04 Official page ↗
Aliases
CVE-2023-38208
Ecosystem
Packagist
Packages
magento/community-edition, magento/project-community-edition
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
Weaknesses
CWE-78
Reviewed
2025-03-04

Affected packages

• Packagist magento/community-edition: 2.4.6 (no fix yet) • Packagist magento/community-edition: 2.4.5 (no fix yet) • Packagist magento/community-edition: 2.4.4 (no fix yet) • Packagist magento/community-edition: >= 2.4.6-p1, < 2.4.6-p2 → fixed in 2.4.6-p2 • Packagist magento/community-edition: >= 2.4.5-p1, < 2.4.5-p4 → fixed in 2.4.5-p4 • Packagist magento/community-edition: >= 2.4.4-p1, < 2.4.4-p5 → fixed in 2.4.4-p5 • Packagist magento/project-community-edition: <= 2.0.2 (no fix yet)

Description

Adobe Commerce versions 2.4.6-p1 (and earlier), 2.4.5-p3 (and earlier) and 2.4.4-p4 (and earlier) are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead to arbitrary code execution by an admin-privilege authenticated attacker. Exploitation of this issue does not require user interaction.

Related

Alias · CVE (1)

  • CVE-2023-38208 Adobe Commerce versions 2.4.6-p1 (and earlier), 2.4.5-p3 (and earlier) and 2.4.4-p4 (and earlier) are affected by an Improper… vulnerability

Weakness · CWE (1)

  • CWE-78 Improper Neutralization of Special Elements used in an OS Command weakness

References