GitHub Advisoryadvisory · Go
GHSA-mxxh-fmjq-j6x4 Mattermost doesn't validate whether users were correctly owned by the correct Connected Workspace
LOW
Official page ↗
- Aliases
- CVE-2026-27769
- Ecosystem
- Go
- Packages
- github.com/mattermost/mattermost-server
- Severity
- Low
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-862
- Reviewed
- 2026-04-28
Affected packages
• Go github.com/mattermost/mattermost-server: >= 8.0.0-20250721062209-4952acea88ce, < 8.0.0-20260316060126-bc1a2b34b1f9 → fixed in 8.0.0-20260316060126-bc1a2b34b1f9
Description
Mattermost versions 10.11.x <= 10.11.12 fail to validate whether users were correctly owned by the correct Connected Workspace which allows a malicious remote server connected using the Conntexted Workspaces feature to change the displayed status of local users via the Connected Workspaces API. Mattermost Advisory ID: MMSA-2026-00603.
Related
Alias · CVE (1)
- CVE-2026-27769 Mattermost versions 10.11.x <= 10.11.12 fail to validate whether users were correctly owned by the correct Connected Workspace which allows… vulnerability
Weakness · CWE (1)
- CWE-862 Missing Authorization weakness