GitHub Advisoryadvisory · RubyGems, PyPI

GHSA-p25m-jpj4-qcrr Denial of Service Vulnerability in gRPC TCP Server (Posix-compatible platforms)

HIGH Published 2023-09-13 Modified 2026-01-12 Official page ↗
Aliases
CVE-2023-4785
Ecosystem
RubyGems, PyPI
Packages
grpc, grpcio
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Weaknesses
CWE-248
Reviewed
2024-02-02

Affected packages

• RubyGems grpc: >= 1.56.0, < 1.56.2 → fixed in 1.56.2 • RubyGems grpc: >= 1.55.0, < 1.55.3 → fixed in 1.55.3 • RubyGems grpc: >= 1.54.0, < 1.54.3 → fixed in 1.54.3 • RubyGems grpc: >= 1.53.0, < 1.53.2 → fixed in 1.53.2 • PyPI grpcio: >= 1.55.0, < 1.55.3 → fixed in 1.55.3 • PyPI grpcio: >= 1.54.0, < 1.54.3 → fixed in 1.54.3 • PyPI grpcio: >= 1.53.0, < 1.53.2 → fixed in 1.53.2

Description

Lack of error handling in the TCP server in Google's gRPC starting version 1.23 on posix-compatible platforms (ex. Linux) allows an attacker to cause a denial of service by initiating a significant number of connections with the server. Note that gRPC C++ Python, and Ruby are affected, but gRPC Java, and Go are NOT affected.

Related

Alias · CVE (1)

  • CVE-2023-4785 Lack of error handling in the TCP server in Google's gRPC starting version 1.23 on posix-compatible platforms (ex. vulnerability

Weakness · CWE (1)

  • CWE-248 Uncaught Exception weakness

References