GitHub Advisoryadvisory · Maven
GHSA-p265-xr98-3vmr Incorrect Authorization in Jenkins
MEDIUM
Official page ↗
- Aliases
- CVE-2018-1999003
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.main:jenkins-core
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- Weaknesses
- CWE-863
- Reviewed
- 2022-06-28
Affected packages
• Maven org.jenkins-ci.main:jenkins-core: < 2.121.2 → fixed in 2.121.2
• Maven org.jenkins-ci.main:jenkins-core: >= 2.122, < 2.133 → fixed in 2.133
Description
A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in Queue.java that allows attackers with Overall/Read permission to cancel queued builds.
Related
Alias · CVE (1)
- CVE-2018-1999003 A Improper authorization vulnerability exists in Jenkins 2.132 and earlier, 2.121.1 and earlier in Queue.java that allows attackers with… vulnerability
Weakness · CWE (1)
- CWE-863 Incorrect Authorization weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1999003 advisory
- https://github.com/jenkinsci/jenkins/commit/af9e11c9941487f69ec1a95c65958fc208064e7a web
- https://github.com/jenkinsci/jenkins package
- https://jenkins.io/security/advisory/2018-07-18/#SECURITY-891 web
- https://www.oracle.com/security-alerts/cpuapr2022.html web