GitHub Advisoryadvisory · Packagist

GHSA-p2gh-cfq4-4wjc Protobuf: Denial of Service issue through malicious messages containing negative varints or deep recursion

HIGH Published 2026-03-25 Modified 2026-04-16 Official page ↗
Aliases
CVE-2026-6409
Ecosystem
Packagist
Packages
google/protobuf
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
Weaknesses
CWE-400
Reviewed
2026-03-25

Affected packages

• Packagist google/protobuf: < 4.33.6 → fixed in 4.33.6

Description

Impact A Denial of Service (DoS) vulnerability exists in the Protobuf PHP library during the parsing of untrusted input. Maliciously structured messages—specifically those containing negative `varint`s or deep recursion—can be used to crash the application, impacting service availability. Patches Patches have been released to 5.34.0-RC1 and 4.33.6.

Related

Alias · CVE (1)

  • CVE-2026-6409 A Denial of Service (DoS) vulnerability exists in the Protobuf PHP library during the parsing of untrusted input. vulnerability

Weakness · CWE (1)

  • CWE-400 Uncontrolled Resource Consumption weakness

References