GitHub Advisoryadvisory · Go
GHSA-p2h2-3vg9-4p87 Connecting to a malicious Codespaces via GH CLI could allow command execution on the user's computer
HIGH
Official page ↗
- Aliases
- CVE-2024-52308
- Ecosystem
- Go
- Packages
- github.com/cli/cli/v2, github.com/cli/cli
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
- Weaknesses
- CWE-77
- Reviewed
- 2024-11-14
Affected packages
• Go github.com/cli/cli/v2: < 2.62.0 → fixed in 2.62.0
• Go github.com/cli/cli: < 2.62.0 → fixed in 2.62.0
Description
Summary
A security vulnerability has been identified in GitHub CLI that could allow remote code execution (RCE) when users connect to a malicious Codespace SSH server and use the `gh codespace ssh` or `gh codespace logs` commands.
Details
The vulnerability stems from the way GitHub CLI handles SSH connection details when executing commands. When developers connect to remote Codespaces, they typically use a SSH server running within a devcontainer, often provided through the default devcontainer image. GitHub CLI retrieves SSH connection details, such as remote username, which is used in executing `ssh` commands for `gh codespace ssh` or `gh codespace logs` commands.
This exploit occurs when a malicious third-party devcontainer contains a modified SSH server that injects `ssh` arguments within the SSH connection details. `gh codespace ssh` and `gh codespace logs` commands could execute arbitrary code on the user's workstation if the remote username contains something like `-oProxyCommand="echo hacked" #`. The `-oProxyCommand` flag causes `ssh` to execute the provided command while `#` shell comment causes any other `ssh` arguments to be ignored.
In `2.62.0`, the remote username information is being validated before being used.
Impact
Successful exploitation could lead to arbitrary code execution on the user's workstation, potentially compromising the user's data and system.
Remediation and Mitigation
1. Upgrade `gh` to `2.62.0`
2. Exercise caution when using custom devcontainer images, prefer default or pre-built devcontainers from trusted sources.
Related
Alias · CVE (1)
- CVE-2024-52308 The GitHub CLI version 2.6.1 and earlier are vulnerable to remote code execution through a malicious codespace SSH server when using `gh… vulnerability
Weakness · CWE (1)
- CWE-77 Improper Neutralization of Special Elements used in a Command weakness