GitHub Advisoryadvisory · Packagist

GHSA-p2h4-7fp3-cmh8 TYPO3 Disclosure of Information about Installed Extensions

MEDIUM Published 2024-05-30 Modified 2024-05-30 Official page ↗
Ecosystem
Packagist
Packages
typo3/cms-core
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Weaknesses
CWE-200
Reviewed
2024-05-30

Affected packages

• Packagist typo3/cms-core: >= 8.0.0, < 8.7.23 → fixed in 8.7.23 • Packagist typo3/cms-core: >= 9.0.0, < 9.5.4 → fixed in 9.5.4

Description

It has been discovered that mechanisms used for configuration of RequireJS package loading are susceptible to information disclosure. This way a potential attack can retrieve additional information about installed system and third party extensions.

Related

Weakness · CWE (1)

  • CWE-200 Exposure of Sensitive Information to an Unauthorized Actor weakness

References