GitHub Advisoryadvisory · Maven
GHSA-p2j7-6g9h-32xh Cross site scripting in Shopizer
MEDIUM
Official page ↗
- Aliases
- CVE-2022-23059
- Ecosystem
- Maven
- Packages
- com.shopizer:shopizer
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2022-04-07
Affected packages
• Maven com.shopizer:shopizer: >= 2.0.2, < 3.0.0 → fixed in 3.0.0
Description
A Stored Cross Site Scripting (XSS) vulnerability exists in Shopizer versions v2.0.2 through v2.17.0 via the “Manage Images” tab, which allows an attacker to upload a SVG file containing malicious JavaScript code.
Related
Alias · CVE (1)
- CVE-2022-23059 A Stored Cross Site Scripting (XSS) vulnerability exists in Shopizer versions 2.0 through 2.17.0 via the “Manage Images” tab, which allows… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness