GitHub Advisoryadvisory · Packagist

GHSA-p2v5-xcqm-4fv6 silverstripe/taxonomy SQL Injection vulnerability

HIGH Published 2024-05-28 Modified 2024-05-28 Official page ↗
Ecosystem
Packagist
Packages
silverstripe/taxonomy
Severity
High
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-89
Reviewed
2024-05-28

Affected packages

• Packagist silverstripe/taxonomy: >= 1.3.0, < 1.3.1 → fixed in 1.3.1 • Packagist silverstripe/taxonomy: >= 2.0.0, < 2.0.1 → fixed in 2.0.1

Description

There is a vulnerability in silverstripe/taxonomy module that allows SQL injection. This affected controller (`TaxonomyDirectoryController`) is disabled by default and must be enabled by a developer for the exploit to be possible.

Related

Weakness · CWE (1)

  • CWE-89 Improper Neutralization of Special Elements used in an SQL Command weakness

References