GitHub Advisoryadvisory · RubyGems

GHSA-p33q-4h4m-j994 Inline SVG vulnerable to Cross-site Scripting

MEDIUM Published 2023-01-07 Modified 2023-01-12 Official page ↗
Aliases
CVE-2020-36644
Ecosystem
RubyGems
Packages
inline_svg
Severity
Moderate
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2023-01-09

Affected packages

• RubyGems inline_svg: < 1.7.2 → fixed in 1.7.2

Description

A vulnerability has been found in jamesmartin Inline SVG up to 1.7.1 and classified as problematic. Affected by this vulnerability is an unknown functionality of the file `lib/inline_svg/action_view/helpers.rb` of the component `URL Parameter Handler`. The manipulation of the argument filename leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.7.2 is able to address this issue. The name of the patch is f5363b351508486021f99e083c92068cf2943621. It is recommended to upgrade the affected component. The identifier VDB-217597 was assigned to this vulnerability.

Related

Alias · CVE (1)

  • CVE-2020-36644 A vulnerability has been found in jamesmartin Inline SVG up to 1.7.1 and classified as problematic. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References