GitHub Advisoryadvisory · Maven

GHSA-p3g4-9xfv-wq9v Arbitrary code execution due to incomplete sandbox protection in Pipeline: Supporting APIs Plugin

HIGH Published 2022-05-14 Modified 2024-01-30 Official page ↗
Aliases
CVE-2018-1000058
Ecosystem
Maven
Packages
org.jenkins-ci.plugins.workflow:workflow-support
Severity
High
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Weaknesses
CWE-502
Reviewed
2024-01-30

Affected packages

• Maven org.jenkins-ci.plugins.workflow:workflow-support: < 2.18 → fixed in 2.18

Description

Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code execution due to incomplete sandbox protection: Methods related to Java deserialization like readResolve implemented in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.

Related

Alias · CVE (1)

  • CVE-2018-1000058 Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code execution due to incomplete sandbox protection: Methods… vulnerability

Weakness · CWE (1)

  • CWE-502 Deserialization of Untrusted Data weakness

References