GitHub Advisoryadvisory · npm

GHSA-p3rg-hrf9-w9gj n8n: DOM-Based XSS via Unsandboxed iframe srcdoc in HTML Preview

HIGH Published 2026-07-22 Modified 2026-07-22 Official page ↗
Aliases
CVE-2026-65597
Ecosystem
npm
Packages
n8n
Severity
High
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:L/VA:N/SC:H/SI:L/SA:N
Weaknesses
CWE-79
Reviewed
2026-07-22

Affected packages

• npm n8n: < 1.123.64 → fixed in 1.123.64 • npm n8n: >= 2.30.0, < 2.30.1 → fixed in 2.30.1 • npm n8n: >= 2.0.0-rc.0, < 2.29.8 → fixed in 2.29.8

Description

Impact The HTML preview renders execution output into an `iframe srcdoc` without `sandbox`, so a sanitizer bypass lets injected script run same-origin as the editor. When a victim opens the preview, it can call authenticated APIs with their session. An account with `global:member` privileges can exploit it. Patches The issue has been fixed in n8n versions 1.123.64, 2.29.8, and 2.30.1. Users should upgrade to one of these versions or later to remediate the vulnerability. Workarounds If upgrading is not immediately possible, administrators should consider the following temporary mitigations: • Restrict n8n instance access to fully trusted users only. • Set the `N8N_CONTENT_SECURITY_POLICY` environment variable to a policy that blocks inline scripts. • Avoid exposing workflows that render externally-controlled input into the HTML node or binary HTML preview to untrusted users. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.

Related

Alias · CVE (1)

  • CVE-2026-65597 n8n before 1.123.64, 2.x before 2.29.8, and before 2.30.1 contains a DOM-based cross-site scripting vulnerability in the HTML preview,… vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References