GitHub Advisoryadvisory · RubyGems

GHSA-p463-639r-q9g9 Dragonfly Code Injection vulnerability

HIGH Published 2017-10-24 Modified 2025-04-14 Official page ↗
Aliases
CVE-2013-1756
Ecosystem
RubyGems
Packages
dragonfly
Severity
High
Weaknesses
CWE-94
Reviewed
2020-06-16

Affected packages

• RubyGems dragonfly: >= 0.7, < 0.8.6 → fixed in 0.8.6 • RubyGems dragonfly: >= 0.9, < 0.9.13 → fixed in 0.9.13

Description

The Dragonfly gem 0.7 before 0.8.6 and 0.9.x before 0.9.13 for Ruby, when used with Ruby on Rails, allows remote attackers to execute arbitrary code via a crafted request.

Related

Alias · CVE (1)

  • CVE-2013-1756 The Dragonfly gem 0.7 before 0.8.6 and 0.9.x before 0.9.13 for Ruby, when used with Ruby on Rails, allows remote attackers to execute… vulnerability

Weakness · CWE (1)

  • CWE-94 Improper Control of Generation of Code weakness

References