GitHub Advisoryadvisory · Packagist
GHSA-p4g7-wjhq-9r2h PayPal PHP Merchant SDK Cross-site scripting (XSS) vulnerability
MEDIUM
Official page ↗
- Aliases
- CVE-2017-6099
- Ecosystem
- Packagist
- Packages
- paypal/merchant-sdk-php
- Severity
- Moderate
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2024-04-25
Affected packages
• Packagist paypal/merchant-sdk-php: >= 3.0.0, < 3.12.0 → fixed in 3.12.0
Description
Cross-site scripting (XSS) vulnerability in GetAuthDetails.html.php in PayPal PHP Merchant SDK (aka merchant-sdk-php) 3.9.1 allows remote attackers to inject arbitrary web script or HTML via the token parameter.
Related
Alias · CVE (1)
- CVE-2017-6099 Cross-site scripting (XSS) vulnerability in GetAuthDetails.html.php in PayPal PHP Merchant SDK (aka merchant-sdk-php) 3.9.1 allows remote… vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness