GitHub Advisoryadvisory · PyPI
GHSA-p4hh-mq57-gq8x Signify allows a remote attacker to escalate privileges via the signed_data.py and the context.py components
HIGH
Official page ↗
- Aliases
- CVE-2025-70887
- Ecosystem
- PyPI
- Packages
- signify
- Severity
- High
- CVSS vector
- CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N
- Weaknesses
- CWE-269
- Reviewed
- 2026-03-27
Affected packages
• PyPI signify: < 0.9.2 → fixed in 0.9.2
Description
An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py components
Related
Alias · CVE (1)
- CVE-2025-70887 An issue in ralphje Signify before v.0.9.2 allows a remote attacker to escalate privileges via the signed_data.py and the context.py… vulnerability
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2025-70887 advisory
- https://github.com/mtrojnar/osslsigncode/issues/475 web
- https://github.com/ralphje/signify/issues/60 web
- https://github.com/mtrojnar/osslsigncode/pull/477 web
- https://github.com/ralphje/signify/commit/64f21c0cc06cea0536370686ca3ba7a01e4adaa8 web
- https://github.com/mtrojnar/osslsigncode/releases/tag/2.11 web
- https://github.com/ralphje/signify package