GitHub Advisoryadvisory · Maven
GHSA-p4p5-3v2j-w5rv Improper Privilege Management in Jenkins
HIGH
Official page ↗
- Aliases
- CVE-2018-1000865
- Ecosystem
- Maven
- Packages
- org.jenkins-ci.plugins:script-security
- Severity
- High
- CVSS vector
- CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- Weaknesses
- CWE-269
- Reviewed
- 2022-06-30
Affected packages
• Maven org.jenkins-ci.plugins:script-security: < 1.48 → fixed in 1.48
Description
A sandbox bypass vulnerability exists in Script Security Plugin 1.47 and earlier in groovy-sandbox/src/main/java/org/kohsuke/groovy/sandbox/SandboxTransformer.java that allows attackers with Job/Configure permission to execute arbitrary code on the Jenkins master JVM, if plugins using the Groovy sandbox are installed.
Related
Alias · CVE (1)
- CVE-2018-1000865 A sandbox bypass vulnerability exists in Script Security Plugin 1.47 and earlier in… vulnerability
Weakness · CWE (1)
- CWE-269 Improper Privilege Management weakness
References
- https://nvd.nist.gov/vuln/detail/CVE-2018-1000865 advisory
- https://github.com/jenkinsci/script-security-plugin/commit/16c862ae9d4038a3edbd8bdfb0fd1401a509d56b web
- https://access.redhat.com/errata/RHBA-2019:0326 web
- https://access.redhat.com/errata/RHBA-2019:0327 web
- https://jenkins.io/security/advisory/2018-10-29/#SECURITY-1186 web