GitHub Advisoryadvisory · PyPI

GHSA-p62g-jhg6-v3rq Code Injection, Race Condition, and Execution with Unnecessary Privileges in Ansible

MEDIUM Published 2021-04-07 Modified 2024-11-18 Official page ↗
Aliases
CVE-2020-10684
Ecosystem
PyPI
Packages
ansible
Severity
Moderate
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
Weaknesses
CWE-250, CWE-362, CWE-862, CWE-94
Reviewed
2021-04-05

Affected packages

• PyPI ansible: >= 2.7.0a1, < 2.7.17 → fixed in 2.7.17 • PyPI ansible: >= 2.8.0a1, < 2.8.11 → fixed in 2.8.11 • PyPI ansible: >= 2.9.0a1, < 2.9.7 → fixed in 2.9.7

Description

A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.11, and 2.9.7 respectively, when using ansible_facts as a subkey of itself and promoting it to a variable when inject is enabled, overwriting the ansible_facts after the clean. An attacker could take advantage of this by altering the ansible_facts, such as ansible_hosts, users and any other key data which would lead into privilege escalation or code injection.

Related

Alias · CVE (1)

  • CVE-2020-10684 A flaw was found in Ansible Engine, all versions 2.7.x, 2.8.x and 2.9.x prior to 2.7.17, 2.8.9 and 2.9.6 respectively, when using… vulnerability

Weakness · CWE (4)

  • CWE-250 Execution with Unnecessary Privileges weakness
  • CWE-362 Concurrent Execution using Shared Resource with Improper Synchronization weakness
  • CWE-862 Missing Authorization weakness
  • CWE-94 Improper Control of Generation of Code weakness

References