GitHub Advisoryadvisory · Go
GHSA-p64j-r5f4-pwwx Improper Validation of Array Index in GJSON
HIGH
Official page ↗
- Aliases
- CVE-2020-36067
- Ecosystem
- Go
- Packages
- github.com/tidwall/gjson
- Severity
- High
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- Weaknesses
- CWE-129
- Reviewed
- 2023-02-06
Affected packages
• Go github.com/tidwall/gjson: < 1.6.6 → fixed in 1.6.6
Description
GJSON < 1.6.6 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call.
Related
Alias · CVE (1)
- CVE-2020-36067 GJSON <=v1.6.5 allows attackers to cause a denial of service (panic: runtime error: slice bounds out of range) via a crafted GET call. vulnerability
Weakness · CWE (1)
- CWE-129 Improper Validation of Array Index weakness