GitHub Advisoryadvisory · Maven

GHSA-p66x-2cv9-qq3v Arbitrary code execution in Apache Commons BeanUtils

HIGH Published 2020-06-10 Modified 2024-06-05 Official page ↗
Aliases
CVE-2014-0114
Ecosystem
Maven
Packages
commons-beanutils:commons-beanutils
Severity
High
Weaknesses
CWE-20
Reviewed
2020-06-10

Affected packages

• Maven commons-beanutils:commons-beanutils: >= 1.8.0, < 1.9.4 → fixed in 1.9.4

Description

Apache Commons BeanUtils, as distributed in lib/commons-beanutils-1.8.0.jar in Apache Struts 1.x through 1.3.10 and in other products requiring commons-beanutils through 1.9.2, does not suppress the class property, which allows remote attackers to "manipulate" the ClassLoader and execute arbitrary code via the class parameter, as demonstrated by the passing of this parameter to the getClass method of the ActionForm object in Struts 1.

Related

Alias · CVE (1)

  • CVE-2014-0114 Apache Commons BeanUtils, as distributed in lib/commons-beanutils-1.8.0.jar in Apache Struts 1.x through 1.3.10 and in other products… vulnerability

Weakness · CWE (1)

  • CWE-20 Improper Input Validation weakness

References