GitHub Advisoryadvisory · RubyGems

GHSA-p692-7mm3-3fxg actionpack is vulnerable to remote bypass authentication

LOW Published 2017-10-24 Modified 2023-07-31 Official page ↗
Aliases
CVE-2015-7576
Ecosystem
RubyGems
Packages
actionpack
Severity
Low
CVSS vector
CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N
Reviewed
2020-06-16

Affected packages

• RubyGems actionpack: >= 3.1.0, < 3.2.22.1 → fixed in 3.2.22.1 • RubyGems actionpack: >= 4.0.0, < 4.1.14.1 → fixed in 4.1.14.1

Description

The http_basic_authenticate_with method in actionpack/lib/action_controller/metal/http_authentication.rb in the Basic Authentication implementation in Action Controller in Ruby on Rails before 3.2.22.1, 4.0.x and 4.1.x before 4.1.14.1, 4.2.x before 4.2.5.1, and 5.x before 5.0.0.beta1.1 does not use a constant-time algorithm for verifying credentials, which makes it easier for remote attackers to bypass authentication by measuring timing differences.

Related

Alias · CVE (1)

  • CVE-2015-7576 The http_basic_authenticate_with method in actionpack/lib/action_controller/metal/http_authentication.rb in the Basic Authentication… vulnerability

References