GitHub Advisoryadvisory · PyPI

GHSA-p6h9-gw49-rqm4 markdown2 is vulnerable to cross-site scripting

MEDIUM Published 2018-07-12 Modified 2024-09-30 Official page ↗
Aliases
CVE-2018-5773
Ecosystem
PyPI
Packages
markdown2
Severity
Moderate
CVSS vector
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Weaknesses
CWE-79
Reviewed
2020-06-16

Affected packages

• PyPI markdown2: < 2.3.6 → fixed in 2.3.6

Description

An issue was discovered in `markdown2` (aka python-markdown2) through 2.3.5. The `safe_mode` feature, which is supposed to sanitize user input against XSS, is flawed and does not escape the input properly. With a crafted payload, XSS can be triggered, as demonstrated by omitting the final `>` character from an IMG tag.

Related

Alias · CVE (1)

  • CVE-2018-5773 An issue was discovered in markdown2 (aka python-markdown2) through 2.3.5. vulnerability

Weakness · CWE (1)

  • CWE-79 Improper Neutralization of Input During Web Page Generation weakness

References