GitHub Advisoryadvisory · PyPI, npm
GHSA-p6rw-44q7-3fw4 Stored XSS in Jupyter nbdime
MEDIUM
Official page ↗
- Aliases
- CVE-2021-41134
- Ecosystem
- PyPI, npm
- Packages
- nbdime, nbdime-jupyterlab
- Severity
- Moderate
- CVSS vector
- CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N
- Weaknesses
- CWE-79
- Reviewed
- 2021-11-03
Affected packages
• PyPI nbdime: < 1.1.1 → fixed in 1.1.1
• PyPI nbdime: >= 2.0.0, < 2.1.1 → fixed in 2.1.1
• PyPI nbdime: >= 3.0.0, < 3.1.1 → fixed in 3.1.1
• npm nbdime: < 5.0.2 → fixed in 5.0.2
• npm nbdime: >= 6.0.0, < 6.1.2 → fixed in 6.1.2
• npm nbdime-jupyterlab: < 1.0.1 → fixed in 1.0.1
• npm nbdime-jupyterlab: >= 2.0.0, < 2.1.1 → fixed in 2.1.1
Description
Impact
Improper handling of user controlled input caused a stored cross-site scripting (XSS) vulnerability. All previous versions of nbdime are affected.
Patches
Security patches will be released for each of the major versions of the nbdime packages since version 1.x of the nbdime python package.
Python
• nbdime 1.x: Patched in v. 1.1.1
• nbdime 2.x: Patched in v. 2.1.1
• nbdime 3.x: Patched in v. 3.1.1
npm
• nbdime 6.x version: Patched in 6.1.2
• nbdime 5.x version: Patched in 5.0.2
• nbdime-jupyterlab 1.x version: Patched in 1.0.1
• nbdime-jupyterlab 2.x version: Patched in 2.1.1
For more information
If you have any questions or comments about this advisory email us at [email protected].
Related
Alias · CVE (1)
- CVE-2021-41134 nbdime provides tools for diffing and merging of Jupyter Notebooks. vulnerability
Weakness · CWE (1)
- CWE-79 Improper Neutralization of Input During Web Page Generation weakness
References
- https://github.com/jupyter/nbdime/security/advisories/GHSA-p6rw-44q7-3fw4 web
- https://nvd.nist.gov/vuln/detail/CVE-2021-41134 advisory
- https://github.com/jupyter/nbdime/commit/e44a5cc7677f24b45ebafc756db49058c2f750ea web
- https://github.com/jupyter/nbdime package
- https://github.com/pypa/advisory-database/tree/main/vulns/nbdime/PYSEC-2021-428.yaml web